summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAmos Bird2019-12-09 00:36:54 +0800
committerAmos Bird2019-12-09 00:36:54 +0800
commit77010e5e80b3a2f5fc86c304cb7cf3484b6500a8 (patch)
tree9e05abd75ce776c259764867ceb3b000c4c07901 /PKGBUILD
downloadaur-fcitx-dbus-commit-string.tar.gz
Add fcitx-dbus-commit-string package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d6d384385851
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Amos Bird <amosbird@gmail.com>
+
+pkgname=fcitx-dbus-commit-string
+pkgver=v1.0.r0.g48a3951
+pkgrel=1
+pkgdesc='An add-on for fcitx to commit string via D-Bus'
+arch=('x86_64')
+url="https://github.com/amosbird/${pkgname}"
+license=('custom:MIT')
+depends=('fcitx>=4.2.9.2' 'dbus>=1.1.0')
+makedepends=('cmake')
+source=("${pkgname}::git+https://github.com/amosbird/${pkgname}.git")
+md5sums=('SKIP')
+provides=("${pkgname}=${pkgver%%.r*}-${pkgrel}")
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$pkgname"
+ mkdir build
+ cd build
+ cmake ..
+ make
+}
+
+package() {
+ cd "$pkgname"/build
+ make DESTDIR="$pkgdir" install
+}