summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCaleb Maclennan2024-04-27 16:47:15 +0300
committerCaleb Maclennan2024-04-27 16:47:15 +0300
commite1f2a511bc6c2ed133610e27cc57230f430c0723 (patch)
tree10bdee9f12a45d47e177e5aa03200cf168bd529e /PKGBUILD
parent933988cc08932bac3189a884006ef4ea765165c9 (diff)
downloadaur-fdiff.tar.gz
upgpkg: fdiff 3.0.0-4
Rebuild for Python 3.12, cleanup packaging odds and ends
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 53feb93441bd..48a8f64fbe7c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,22 @@
pkgname=fdiff
pkgver=3.0.0
-pkgrel=3
+pkgrel=4
pkgdesc='An OpenType table diff tool for fonts based on the fontTools TTX format'
arch=(any)
url="https://github.com/source-foundry/$pkgname"
license=(MIT)
-_py_deps=(aiodns
- aiofiles
- aiohttp
- fonttools
- rich)
+_pydeps=(aiodns
+ aiofiles
+ aiohttp
+ fonttools
+ rich)
depends=(python
- "${_py_deps[@]/#/python-}")
+ "${_pydeps[@]/#/python-}")
makedepends=(python-{build,installer,wheel}
python-setuptools)
_archive="$pkgname-$pkgver"
-source=("$_archive.tar.gz::$url/archive/v$pkgver.tar.gz")
+source=("$url/archive/v$pkgver/$_archive.tar.gz")
sha256sums=('4d00db17bb5d9980d92a395ceac43559c11c35347c43a12e599123745fe67f7d')
build() {