summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBruce Zhang2020-06-07 19:22:46 +0800
committerBruce Zhang2020-06-07 19:22:46 +0800
commite075e2248b809a8bca5d6a57f0a39e561f706b42 (patch)
tree5644961d1d10475eae0bf7ad4ae4e98d5610ef58 /PKGBUILD
downloadaur-feeluown-local.tar.gz
Initial upload: feeluown-local 0.2.1-1
Initial upload: feeluown-netease 0.4.2-1 Initial upload: feeluown-qqmusic 0.2-1 Initial upload: feeluown-xiami 0.2.3-1 fuo packages
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2a1528cfefe5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Bruce Zhang <zttt183525594@gmail.com>
+_name=fuo_local
+pkgname=feeluown-local
+pkgver=0.2.1
+pkgrel=1
+pkgdesc="feeluown local plugin"
+arch=('any')
+url="https://github.com/feeluown/feeluown-local"
+license=('GPL3')
+depends=('feeluown' 'python-marshmallow' 'python-mutagen' 'python-fuzzywuzzy')
+makedepends=('python-setuptools' 'python-pip')
+source=(
+ "https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz"
+)
+sha256sums=('a799a428e5c3cf8696e8dda124d7e7ac7dce1b1525b1100df40c748e4b13d445')
+groups=('feeluown-full')
+
+build() {
+ cd "$_name-$pkgver"
+ LANG=en_US.UTF-8 python setup.py build
+}
+
+package() {
+ cd "$_name-$pkgver"
+ LANG=en_US.UTF-8 python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}