summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNathaniel Chin2024-03-21 01:45:17 +0800
committerNathaniel Chin2024-03-21 01:45:17 +0800
commitc4b30c3127b19da42e0a7f46c4970aa042895905 (patch)
tree4be578d0b11cc412a943a7bf35d21ce205c812e9 /PKGBUILD
parent4c3ac9443240eeeb215c742813669d5804b98428 (diff)
downloadaur-ffmpeg-amd-full.tar.gz
Fix build with newer vulkan-headers
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a8b38224c675..2408479a817b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=ffmpeg-amd-full
pkgver=6.1.1
-pkgrel=2
+pkgrel=3
pkgdesc='Complete solution to record, convert and stream audio and video (all possible features for AMD)'
arch=('x86_64')
url='https://www.ffmpeg.org/'
@@ -135,6 +135,7 @@ source=("https://ffmpeg.org/releases/ffmpeg-${pkgver}.tar.xz"{,.asc}
'060-ffmpeg-fix-segfault-with-avisynthplus.patch'
'070-ffmpeg-fix-lensfun-detection.patch'::'https://git.ffmpeg.org/gitweb/ffmpeg.git/patch/e1c1dc8347f13104bc21e4100fcf4d4dddf5e5d8'
'080-ffmpeg-glslang14-fix.patch'::'https://git.ffmpeg.org/gitweb/ffmpeg.git/patch/e43615fc2ab27d562ed7e087803f4a364a7d1175'
+ '090-ffmpeg-vulkan-headers1.3.279-fix.patch'::'https://git.ffmpeg.org/gitweb/ffmpeg.git/patch/fef22c87ada4517441701e6e61e062c9f4399c8e'
'LICENSE')
sha256sums=('8684f4b00f94b85461884c3719382f1261f0d9eb3d59640a1f4ac0873616f968'
'SKIP'
@@ -144,6 +145,7 @@ sha256sums=('8684f4b00f94b85461884c3719382f1261f0d9eb3d59640a1f4ac0873616f968'
'bf563193f450ece58a93db6840c0db33875df945fa81477b9b02fb209d3bf57a'
'2b72fe52ea73fbc1ce7eb70b4c181893c761e30121879ddd5513976232d7adf8'
'cebcc04cac957f6a9c08169765da4c7ef231ebbda225876e210fd60e8582c3d9'
+ 'c2ef9c35082ed2e5989428d086b7bfef1dfe9e0a85e6d259daf46f369f115483'
'04a7176400907fd7db0d69116b99de49e582a6e176b3bfb36a03e50a4cb26a36')
validpgpkeys=('FCF986EA15E6E293A5644F10B4322F04D67658D8')
@@ -156,6 +158,7 @@ prepare() {
patch -d "ffmpeg-${pkgver}" -Np1 -i "${srcdir}/060-ffmpeg-fix-segfault-with-avisynthplus.patch"
patch -d "ffmpeg-${pkgver}" -Np1 -i "${srcdir}/070-ffmpeg-fix-lensfun-detection.patch"
patch -d "ffmpeg-${pkgver}" -Np1 -i "${srcdir}/080-ffmpeg-glslang14-fix.patch"
+ patch -d "ffmpeg-${pkgver}" -Np1 -i "${srcdir}/090-ffmpeg-vulkan-headers1.3.279-fix.patch"
}
build() {