summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2018-05-11 20:05:01 +0000
committerDaniel Bermond2018-05-11 20:05:01 +0000
commitad876af361f7538a8ad257931494d3bd4e94d6bc (patch)
treef16db56672e8e73c742c9f4b5c7b7d8335a42b9d /PKGBUILD
parent19b099058cc879c6abf1b5493588c7caa7223aed (diff)
downloadaur-ad876af361f7538a8ad257931494d3bd4e94d6bc.tar.gz
Fix build
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD161
1 files changed, 86 insertions, 75 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9d3390be6b65..2328b3585ef1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,93 +1,104 @@
-# Maintainer: epitron <chris@ill-logic.com>
+# Maintainer : Daniel Bermond < yahoo-com: danielbermond >
+# Contributor: epitron <chris@ill-logic.com>
# Contributor: Kamran Mackey <kamranm1200@gmail.com>
# Contributor: richteer <richteer at lastprime.net>
# Contributor: DrZaius <lou at fakeoutdoorsman.com>
pkgname=ffmpeg-qsv-git
-pkgver=3.3.r83607.gc9e3952b82
+pkgver=4.1.r91063.g66ba303c53
pkgrel=1
-pkgdesc="Complete solution to record, convert and stream audio and video (git version, with Intel Quick Sync Video hardware acceleration)"
-arch=('i686' 'x86_64')
-license=('GPL3' 'Non-free')
-url="http://ffmpeg.org/"
-depends=('alsa-lib' 'bzip2' 'fontconfig' 'fribidi' 'gmp' 'gnutls' 'gsm' 'lame'
- 'libass' 'libavc1394' 'libbluray' 'libiec61883' 'libmodplug' 'libpulse'
- 'libsoxr' 'libssh' 'libtheora' 'libva' 'libvdpau' 'libwebp'
- 'netcdf' 'opencore-amr' 'openjpeg' 'opus' 'schroedinger' 'sdl' 'speex'
- 'v4l-utils' 'xvidcore' 'zlib' 'libvidstab.so' 'libvorbis.so' 'libvorbisenc.so'
- 'libvpx.so' 'libx264.so' 'libx265.so' 'libfdk-aac'
- 'intel-media-sdk')
-makedepends=('hardening-wrapper' 'ladspa' 'libvdpau' 'yasm' 'git')
+pkgdesc='Complete solution to record, convert and stream audio and video (with Intel Quick Sync Video hardware acceleration, git version)'
+arch=('x86_64')
+url='http://www.ffmpeg.org/'
+license=('GPL3')
+depends=('alsa-lib' 'bzip2' 'fontconfig' 'fribidi' 'glibc' 'gmp' 'gnutls' 'gsm'
+ 'jack' 'lame' 'libavc1394' 'libiec61883' 'libmodplug' 'libpulse'
+ 'libraw1394' 'libsoxr' 'libssh' 'libtheora' 'libvdpau' 'libwebp'
+ 'libx11' 'libxcb' 'libxml2' 'opencore-amr' 'openjpeg2' 'opus' 'sdl2'
+ 'speex' 'v4l-utils' 'xz' 'zlib'
+ 'libomxil-bellagio'
+ 'intel-media-sdk'
+ 'libass.so' 'libbluray.so' 'libfreetype.so' 'libva-drm.so' 'libva.so'
+ 'libva-x11.so' 'libvidstab.so' 'libvorbisenc.so' 'libvorbis.so'
+ 'libvpx.so' 'libx264.so' 'libx265.so' 'libxvidcore.so')
+makedepends=('git' 'ladspa' 'nasm')
optdepends=('ladspa: LADSPA filters')
-provides=('ffmpeg' 'libavcodec.so' 'libavdevice.so' 'libavfilter.so'
- 'libavformat.so' 'libavresample.so' 'libavutil.so' 'libpostproc.so'
- 'libswresample.so' 'libswscale.so')
-conflicts=('ffmpeg' 'ffmpeg-full-git')
+provides=('ffmpeg' 'ffmpeg-git' 'qt-faststart' 'libavcodec.so' 'libavdevice.so'
+ 'libavfilter.so' 'libavformat.so' 'libavresample.so' 'libavutil.so'
+ 'libpostproc.so' 'libswresample.so' 'libswscale.so')
+conflicts=('ffmpeg' 'ffmpeg-git')
source=("$pkgname"::'git://source.ffmpeg.org/ffmpeg.git')
-md5sums=('SKIP')
+sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/$pkgname"
- _ver="$(git describe --tags | sed 's|-[^.]*$||' | sed 's|^n||')"
- _rev="$(git rev-list --count HEAD)"
- _gitid="$(git rev-parse --short HEAD)"
- echo "${_ver}.r${_rev}.g${_gitid}"
+ cd "$pkgname"
+
+ local _version="$( git describe --tags --long | awk -F'-' '{ printf $1 }' | sed 's/^n//')"
+ local _revision="$( git describe --tags --match 'N' | awk -F'-' '{ printf $2 }')"
+ local _shorthash="$(git rev-parse --short HEAD)"
+
+ printf '%s.r%s.g%s' "$_version" "$_revision" "$_shorthash"
}
build() {
- cd "$srcdir/$pkgname"
-
- PKG_CONFIG_PATH=/opt/intel/mediasdk/lib/pkgconfig/ \
- ./configure --prefix=/usr \
- --disable-debug \
- --disable-static \
- --enable-libmfx \
+ cd "$pkgname"
+
+ export PKG_CONFIG_PATH="${PKG_CONFIG_PATH:+${PKG_CONFIG_PATH}:}/opt/intel/mediasdk/lib64/pkgconfig"
+
+ msg2 'Running ffmpeg configure script. Please wait...'
+
+ ./configure \
+ --prefix='/usr' \
+ --disable-debug \
+ --disable-static \
+ --disable-stripping \
--enable-avisynth \
- --enable-avresample \
- --enable-fontconfig \
- --enable-gnutls \
- --enable-gpl \
- --enable-ladspa \
- --enable-libass \
- --enable-libbluray \
- --enable-libfreetype \
- --enable-libfribidi \
- --enable-libgsm \
- --enable-libmodplug \
- --enable-libmp3lame \
- --enable-libopencore_amrnb \
- --enable-libopencore_amrwb \
- --enable-libopenjpeg \
- --enable-libopus \
- --enable-libfdk-aac \
- --enable-libpulse \
- --enable-libschroedinger \
- --enable-libsoxr \
- --enable-libspeex \
- --enable-libssh \
- --enable-libtheora \
- --enable-libv4l2 \
- --enable-libvidstab \
- --enable-libvorbis \
- --enable-libvpx \
- --enable-libwebp \
- --enable-libx264 \
- --enable-libx265 \
- --enable-libxvid \
- --enable-nonfree \
- --enable-shared \
- --enable-version3 \
- --enable-x11grab \
-
- make EXTRA_CFLAGS="$CFLAGS"
- make tools/qt-faststart
- make doc/ff{mpeg,play,server}.1
+ --enable-avresample \
+ --enable-fontconfig \
+ --enable-gmp \
+ --enable-gnutls \
+ --enable-gpl \
+ --enable-ladspa \
+ --enable-libass \
+ --enable-libbluray \
+ --enable-libfreetype \
+ --enable-libfribidi \
+ --enable-libgsm \
+ --enable-libiec61883 \
+ --enable-libmodplug \
+ --enable-libmp3lame \
+ --enable-libopencore_amrnb \
+ --enable-libopencore_amrwb \
+ --enable-libopenjpeg \
+ --enable-libopus \
+ --enable-libpulse \
+ --enable-libsoxr \
+ --enable-libspeex \
+ --enable-libssh \
+ --enable-libtheora \
+ --enable-libv4l2 \
+ --enable-libvidstab \
+ --enable-libvorbis \
+ --enable-libvpx \
+ --enable-libwebp \
+ --enable-libx264 \
+ --enable-libx265 \
+ --enable-libxcb \
+ --enable-libxml2 \
+ --enable-libxvid \
+ --enable-shared \
+ --enable-version3 \
+ --enable-omx \
+ --enable-libmfx
+
+ make
+ make tools/qt-faststart
}
package() {
- cd "$srcdir/$pkgname"
- make DESTDIR="$pkgdir" install install-man
- install -D -m755 tools/qt-faststart "$pkgdir/usr/bin/qt-faststart"
+ cd "$pkgname"
+
+ make DESTDIR="$pkgdir" install
+
+ install -D -m755 tools/qt-faststart "${pkgdir}/usr/bin/qt-faststart"
}
-
-# vim: ts=8 sw=8 et: