summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichel Zou2019-07-29 20:41:10 +0200
committerMichel Zou2019-07-29 20:41:10 +0200
commit1e6def2a313314915a048607387546dd41b4887f (patch)
treeabed9fb527f86129b2d3ffeae9a04eabfa718a0f /PKGBUILD
downloadaur-ffs-git.tar.gz
init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e446d90354de
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+pkgname=ffs-git
+pkgver=r1180.7774ca6
+pkgrel=1
+pkgdesc="FFS is a middleware library for data communication"
+license=('BSD')
+arch=('x86_64')
+url="https://github.com/GTkorvo/ffs"
+depends=('atl' 'dill')
+makedepends=('cmake')
+provides=('ffs')
+conflicts=('ffs')
+source=("git+https://github.com/GTkorvo/ffs.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ffs
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd ffs
+ cmake -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_SKIP_INSTALL_RPATH=ON \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_TESTING=OFF \
+ .
+ make
+}
+
+package() {
+ cd ffs
+ make DESTDIR="$pkgdir" install
+}
+