summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPaul Kasemir2022-08-04 23:26:24 -0600
committerPaul Kasemir2022-08-04 23:26:24 -0600
commit75964cdb7534d433df750e6efffd162c4a9628b0 (patch)
tree9f99b093995b4c3e57962837c3a3acfa6a804db2 /PKGBUILD
parent74222edd14c37980aec5cb1c8c093d353edd3575 (diff)
downloadaur-find-the-command-git.tar.gz
Stop installing the removed systemd timer
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 687ae7092871..3cb50e8b5b5f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,22 @@
# Contributor: Mark Wagie <mark dot wagie at tutanota dot com>
# Contributor: Paul Kasemir <paul.kasemir@gmail.com>
pkgname=find-the-command-git
-pkgver=2.0.r0.g05157f6
+pkgver=2.0.r2.gfecba1a
pkgrel=1
pkgdesc="Advanced command-not-found hook for bash, fish and zsh using the power of pacman"
arch=('any')
url="https://github.com/pkasemir/find-the-command"
-license=('WTFPL')
-depends=('pacman' 'systemd')
+license=('custom:WTFPL')
+depends=('pacman')
optdepends=('fzf: highly recommended for package selection and previews'
- 'pkgfile: provides faster searches than pacman')
+ 'pacman-contrib: for weekly pacman-filesdb-refresh.timer'
+ 'pkgfile: provides faster searches than pacman'
+ 'sudo: helpful for privilege elevation')
makedepends=('git')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
install="${pkgname%-git}.install"
+options=('docs')
source=('git+https://github.com/pkasemir/find-the-command.git')
sha256sums=('SKIP')
@@ -25,8 +28,6 @@ pkgver() {
package() {
cd "$srcdir/${pkgname%-git}"
- install -Dm644 usr/lib/systemd/system/pacman-files{.service,.timer} -t \
- "$pkgdir/usr/lib/systemd/system"
install -Dm644 README.md usr/share/doc/"${pkgname%-git}"/ftc.* -t \
"$pkgdir/usr/share/doc/${pkgname%-git}"
install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/${pkgname%-git}"