summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorxaque2022-07-17 23:25:59 -0700
committerxaque2022-07-17 23:25:59 -0700
commitb4a904a35f31d9445861e9b43df9a7010ef93118 (patch)
tree24166b72f7e1953700bf212bf1b8a086d9b25a15 /PKGBUILD
downloadaur-fire-vst3-bin.tar.gz
Initial commit for v0.9.9
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 17 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8024811ef47e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: xaque <xaque at 🦆 dot com>
+
+pkgname=fire-vst3-bin
+pkgver=0.9.9
+pkgrel=1
+pkgdesc="Fire is a multiband distortion / downsampler plugin developed by Wings"
+arch=("x86_64")
+url="https://github.com/jerryuhoo/Fire"
+license=('AGPL')
+depends=(brotli bzip2 freetype2 gcc-libs glib2 glibc graphite harfbuzz libpng pcre zlib)
+_download_url="https://github.com/jerryuhoo/Fire/releases/download/"
+source=("$pkgname-$pkgver.zip::${_download_url}/v${pkgver}/Fire-Linux.zip")
+sha256sums=("3247a7d15a370d7f2b3c13cfb4e9a26573ae075f60f6ccf024f24f604c9fa16b")
+
+package() {
+ install -Dm755 "Fire-Linux/VST3/Fire.vst3/Contents/x86_64-linux/Fire.so" $pkgdir/usr/lib/vst3/Fire.vst3/Contents/x86_64-linux/Fire.so
+}