summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPierre Dorbais2015-06-20 10:27:10 +0200
committerPierre Dorbais2015-06-20 10:27:10 +0200
commitf0deb9d2d7b2ce0864215118ca93c6347d4a1ebd (patch)
tree86e86e1c1c63b24eae177a06469e9aafe98ee0bd /PKGBUILD
downloadaur-firefox-extension-add-to-search-bar.tar.gz
Intial import to aur4 and md5sum fix
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ab4ec3ae5832
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Pierre Dorbais <pierre at dorbais dot fr>
+
+pkgname=firefox-extension-add-to-search-bar
+pkgver=2.8
+_addons_file=3682
+pkgrel=2
+pkgdesc="Add any search engine to the search bar."
+arch=('any')
+url="https://firefox.maltekraus.de/extensions/add-to-search-bar"
+license=('MPL' 'GPL' 'LGPL')
+depends=('firefox')
+source=("https://addons.cdn.mozilla.net/user-media/addons/${_addons_file}/add_to_search_bar-${pkgver}-fx.xpi")
+md5sums=('e95fae25a54ef043bda414d7c2e60675')
+
+package() {
+ cd $srcdir
+ local emid=$(sed -n '/.*<em:id>\(.*\)<\/em:id>.*/{s//\1/p;q}' install.rdf)
+ local dstdir=$pkgdir/usr/lib/firefox/browser/extensions/${emid}
+ [ -n ${emid} ] || return 1
+ install -d $dstdir
+ cp -R * $dstdir
+ rm $dstdir/*.xpi
+ find $pkgdir -type d -exec chmod 0755 {} \;
+ find $pkgdir -type f -exec chmod 0644 {} \;
+}