summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGoliathLabs2020-05-23 14:53:00 +0200
committerGoliathLabs2020-05-23 14:53:00 +0200
commit2071f5678a37d9aa0bfee2ef48a24511fe4e6e6e (patch)
tree0cb99fc600314a36bf693a336f2e3e5437227d17 /PKGBUILD
parent39516a62a95833582b846f367f46fd36f77521ed (diff)
downloadaur-firefox-extension-feedly-notifier.tar.gz
Updated: 2.24.5
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 13 insertions, 21 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 811edf5141ac..0bff543dcc01 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,14 @@
-# Maintainer: FadeMind <fademind@gmail.com>
+# Maintainer:
+# Contributor: Felix Golatofski <contact@xdfr.de>
+# Contributor: FadeMind <fademind@gmail.com>
# Contributor: Daniel Nagy <danielnagy at gmx de>
-_dver=456474
+_plugin_name=feedly_notifier
+_plugin_version=2.24.5
+_plugin_id=456474
+_plugin_ext="fx"
pkgname=firefox-extension-feedly-notifier
-pkgver=2.11.2
+pkgver=$_plugin_version
pkgrel=1
pkgdesc="Firefox extension for reading news from rss aggregator Feedly"
url="https://addons.mozilla.org/firefox/addon/feedly-notifier/"
@@ -11,24 +16,11 @@ depends=("firefox")
makedepends=('unzip')
license=('MPL2')
arch=('any')
-source=("https://addons.mozilla.org/firefox/downloads/latest/${_dver}/addon-${_dver}-latest.xpi")
-sha256sums=('db85459a0d9c25240f1a8b05c55e6a92aff64acb7c5ce68d9ae68c9f8c5af5f9')
-noextract=(addon-${_dver}-latest.xpi)
-
-pkgver() {
- sed -n '/.*<em:version>\(.*\)<\/em:version>.*/{s//\1/p;q}' install.rdf | cut -f 1 -d-
-}
-
-prepare(){
- unzip -qqo addon-${_dver}-latest.xpi
-}
+source=("https://addons.cdn.mozilla.net/user-media/addons/${_plugin_id}/${_plugin_name}-${_plugin_version}-${_plugin_ext}.xpi")
+sha256sums=('8acc05414031e60fdcb6e7e631b53e046d1f681a0e4892ea7dc32bcfc9613ebf')
+noextract=(addon-${_plugin_id}-latest.xpi)
package() {
- cd "$srcdir"
- emid=$(grep -Pom1 'id>\K[^<]*' install.rdf)
- local dstdir="$pkgdir/usr/lib/firefox/browser/extensions/${emid}"
- install -d "$dstdir"
- rm *.xpi
- cp -dpr --no-preserve=ownership * "$dstdir"
- chmod -R 755 "$dstdir"
+ install -Dm644 "${_plugin_name}-${_plugin_version}-${_plugin_ext}.xpi" "$pkgdir/usr/lib/firefox/browser/extensions/feedlynotifier@olsh.github.io.xpi"
+
}