summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMohammadreza Abdollahzadeh2023-09-06 20:59:50 +0330
committerMohammadreza Abdollahzadeh2023-09-06 20:59:50 +0330
commit779e9ffaebcea0035f3afc91bd2d38ca478692b8 (patch)
treed081920b02f4e87add9a94d3340e15a82169d459 /PKGBUILD
parentf649abead3aa739751c6b351bbd7e74d13830cad (diff)
downloadaur-firefox-extension-uget-integration.tar.gz
upgpkg: firefox-extension-uget-integration 2.1.3.1-1
upstream release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 4 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 79e857f3c169..a001fc2d0748 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,19 @@
# Maintainer: Mohammadreza Abdollahzadeh < morealaz at gmail dot com >
pkgname=firefox-extension-uget-integration
-pkgver=2.1.3
+pkgver=2.1.3.1
pkgrel=1
pkgdesc='uGet Download Manager integration extension for Firefox.'
arch=('any')
url='https://addons.mozilla.org/en-US/firefox/addon/ugetintegration/'
-_gh_url='https://github.com/ugetdm/uget-extension'
license=('GPL3')
depends=('firefox')
groups=('firefox-addons')
-source=("${pkgname}-${pkgver}.zip::${_gh_url}/releases/download/v${pkgver}/uget-integration-firefox.zip")
-noextract=("${pkgname}-${pkgver}.zip")
-sha512sums=('77a1983445cc9ed055cd0483d92f1041b0fd5a32c03579143ddc290472e6d6c9454475a1c091df12bd09a472f683de2751ccc64dff17615da6237eac4edfb32f')
+source=("${pkgname}-${pkgver}.xpi::https://addons.mozilla.org/firefox/downloads/file/911315/ugetintegration-${pkgver}.xpi")
+sha512sums=('1df2a903bd520b065a02cb448ced3ea321bf0b7d85b84836be63b7d6c56a6bab9d23f480cd11ff1f3265ea3df2b01b7634e793321fd8e249942a367d2f0b4928')
package() {
cd ${srcdir}
- install -D -m 644 "${pkgname}-${pkgver}.zip" "${pkgdir}/usr/lib/firefox/browser/extensions/uget-integration@slgobinath.xpi"
+ install -D -m 644 "${pkgname}-${pkgver}.xpi" "${pkgdir}/usr/lib/firefox/browser/extensions/uget-integration@slgobinath.xpi"
}
# vim:set ts=4 sw=4 et: