summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCharlie Wolf2017-04-05 22:26:39 -0700
committerCharlie Wolf2017-04-05 22:26:39 -0700
commitd7f4d4674920e043938f1319ee7d83f9e2b64893 (patch)
tree1d4ef54cb257f861c521259c4d529441e6f799c9 /PKGBUILD
downloadaur-firefox-searchengine-ddghtml.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 17 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e19f307d606b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Charlie Wolf <charlie@wolf.is>
+
+pkgname=firefox-searchengine-ddghtml
+pkgver=1.0
+pkgrel=1
+pkgdesc="Firefox french DuckDuckGo search engine"
+arch=('any')
+url="http://duckduckgo.com/"
+license=('GPL')
+depends=("firefox")
+source=(search-duckduckgo-ssl-html.xml)
+sha512sums=('6fe3dc1ca1583a7d192b8e5c7984029d3228fa95fb01a0e797583fe2e284c17b25f173524d062614e79a91d6fc47bae7f4035a8cedc72367cf5ee51c491916eb')
+validpgpkeys=('3C82931F90299B5DBCC9088B65714E0A9FA612B2')
+
+package() {
+ install -D -m 0644 "${srcdir}"/search-duckduckgo-ssl-html.xml "${pkgdir}"/usr/lib/firefox/distribution/searchplugins/common/search-duckduckgo-ssl-html.xml
+}