summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPaulo Matias2023-04-08 15:24:50 -0300
committerPaulo Matias2023-04-08 15:24:50 -0300
commit6b2c673bb5dfbf9483c7b514b36671fd3eca71f3 (patch)
tree34493175734a99684931daa6576bd5b01d7cb3ba /PKGBUILD
parent3971e5e748a82a6e3e3aab8c36552de4a98a5156 (diff)
downloadaur-6b2c673bb5dfbf9483c7b514b36671fd3eca71f3.tar.gz
Fetch sources using git-cinnabar instead of hg
Recently, Mercurial has been crashing a lot with the mozilla-unified repo in my system. So unfortunately I had to resort to fetching the sources using git-cinnabar, at least for now.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2a03d2302d16..1ee0622ad195 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
pkgname=firefox-wayland-hg
_pkgname=firefox
-pkgver=r684798.b77de0b524d8
+pkgver=r659341.4e0bb3e
pkgrel=1
pkgdesc="Standalone web browser from mozilla.org (mozilla-unified hg, release branding, targeting wayland)"
arch=(x86_64)
@@ -17,7 +17,7 @@ url="https://www.mozilla.org/firefox/"
depends=(gtk3 libxt mime-types dbus-glib
ffmpeg nss-hg ttf-font libpulse xorg-server-xwayland
libvpx libwebp libjpeg zlib icu libevent pipewire)
-makedepends=(mercurial unzip zip diffutils yasm mesa imake inetutils
+makedepends=(git-cinnabar unzip zip diffutils yasm mesa imake inetutils
xorg-server-xvfb autoconf2.13 rust clang llvm jack nodejs cbindgen nasm
python-setuptools lld dump_syms
wasi-compiler-rt wasi-libc wasi-libc++ wasi-libc++abi)
@@ -31,7 +31,7 @@ options=(!emptydirs !makeflags !strip !lto)
_repo=https://hg.mozilla.org/mozilla-unified
conflicts=('firefox')
provides=('firefox')
-source=("hg+$_repo#revision=autoland"
+source=("mozilla-unified::git+hg::$_repo#branch=bookmarks/autoland"
$_pkgname.desktop $_pkgname-symbolic.svg)
sha256sums=('SKIP'
'a9e5264257041c0b968425b5c97436ba48e8d294e1a0f02c59c35461ea245c33'
@@ -51,7 +51,7 @@ _mozilla_api_key=16674381-f021-49de-8622-3021c5942aff
pkgver() {
cd mozilla-unified
- printf "r%s.%s" "$(hg identify -n)" "$(hg identify -i)"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short=7 HEAD)"
}
prepare() {
@@ -131,6 +131,7 @@ build() {
cd mozilla-unified
export MOZ_SOURCE_REPO="$_repo"
+ export MOZ_SOURCE_CHANGESET="$(cd $SRCDEST/mozilla-unified; git cinnabar git2hg bookmarks/autoland)"
export MOZ_NOSPAM=1
export MOZBUILD_STATE_PATH="$srcdir/mozbuild"
export MACH_BUILD_PYTHON_NATIVE_PACKAGE_SOURCE=none