summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNiko Cantero2023-08-18 16:28:04 -0400
committerGitHub2023-08-18 17:28:04 -0300
commit78726a99bc2f5cc06c30cc7b9bd9268d0462374c (patch)
tree4f9f37e85df9e69130ae09d307352fe41273f011 /PKGBUILD
parent06f379f0e8f67fe6b16dde629581a97cb1664e42 (diff)
downloadaur-78726a99bc2f5cc06c30cc7b9bd9268d0462374c.tar.gz
Fix conflict/provide (#5)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 911a7d2a476e..b4522c85f18c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -57,7 +57,7 @@ makedepends=(
wasi-libc
wasi-libc++
wasi-libc++abi
- # Cage, Pixman, Polkit, and XWayland are required for 3 TIER PGO:
+ # Cage, Pixman, Polkit, and XWayland are required for PGO:
# cage
# pixman
# polkit
@@ -80,8 +80,8 @@ options=(
!strip
)
_repo=https://hg.mozilla.org/mozilla-unified
-conflicts=('firefox-nightly')
-provides=('firefox')
+conflicts=('firefox-nightly' 'firefox-hg')
+provides=('firefox-nightly')
source=(
hg+$_repo
$_pkgname.desktop
@@ -150,7 +150,7 @@ prepare() {
# `ac_add_options --enable-lto' and ending with 'export RANLIB=llvm-ranlib`
#
- cat >.mozconfig <<END
+ cat >../mozconfig <<END
ac_add_options --enable-application=browser
mk_add_options MOZ_OBJDIR=${PWD@Q}/obj