summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPaulo Matias2022-03-25 08:04:14 -0300
committerPaulo Matias2022-03-25 08:04:14 -0300
commit9cb0e92995768579658321059e9298e2fcd82dfd (patch)
treece4919002c788b5b5529c04b1c3dd6fd1489ad81 /PKGBUILD
parent0e4d66aed04d1e3cc53286a4d8cd6d1b6bfc3cf8 (diff)
downloadaur-9cb0e92995768579658321059e9298e2fcd82dfd.tar.gz
use vendored python packages to avoid incompatibility
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 2 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 40dd8bcb0375..d52bae3fb4cd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,8 +19,7 @@ depends=(gtk3 libxt mime-types dbus-glib
libvpx libwebp libjpeg zlib icu libevent libpipewire02)
makedepends=(mercurial unzip zip diffutils yasm mesa imake inetutils
xorg-server-xvfb autoconf2.13 rust clang llvm jack nodejs cbindgen nasm
- python-setuptools python-psutil python-zstandard lld dump_syms
- wasi-sdk-git)
+ python-setuptools lld dump_syms wasi-sdk-git)
optdepends=('networkmanager: Location detection via available WiFi networks'
'libnotify: Notification integration'
'pulseaudio: Audio support'
@@ -132,7 +131,7 @@ build() {
export MOZ_SOURCE_REPO="$_repo"
export MOZ_NOSPAM=1
export MOZBUILD_STATE_PATH="$srcdir/mozbuild"
- export MACH_BUILD_PYTHON_NATIVE_PACKAGE_SOURCE=system
+ export MACH_BUILD_PYTHON_NATIVE_PACKAGE_SOURCE=none
# LTO/PGO needs more open files
ulimit -n 4096