summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorL.G. Sarmiento2020-11-25 14:24:42 +0100
committerL.G. Sarmiento2020-11-25 14:24:42 +0100
commit71e5b8a14381beb75254e08b637315e388885b97 (patch)
treed267a5fe45959548cf49825f1992aa0e3dbf9bf9 /PKGBUILD
parente11142440b4fec87d380160c23cfcb9ab0d77cb8 (diff)
downloadaur-fityk-git.tar.gz
dependencies updated
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 9 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d1da718d9b79..7691b72d1961 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Submitter: L.G. Sarmiento <lgsarmientop-ala-unal.edu.co>
pkgname=fityk-git
_pkgname=fityk
-pkgver=r1641.3967c7e
+pkgver=r1713.d3bd1341
pkgrel=1
pkgdesc="A program for nonlinear fitting of analytical functions to data."
url="http://fityk.nieto.pl/"
-arch=('i686' 'x86_64')
+arch=('x86_64')
license=('GPL2')
-depends=('lua' 'wxgtk' 'xylib' 'ruby' 'python')
-makedepends=('boost' 'desktop-file-utils' 'git' 'python2-sphinx' 'swig')
+depends=('xylib' 'boost' 'lua' 'swig')
+makedepends=('git')
optdepends=('gnuplot: can be used with the CLI')
provides=("fityk")
options=('!libtool')
@@ -18,11 +18,11 @@ source=($_pkgname::git+https://github.com/wojdyr/fityk.git
md5sums=('SKIP'
'0f2c2b78511036ea623a9568509bc987')
-#_gitroot="http://github.com/wojdyr/fityk.git"
-
pkgver() {
+
cd ${srcdir}/$_pkgname
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+
}
build() {
@@ -36,9 +36,12 @@ build() {
--prefix=/usr \
--with-wx-config=/usr/bin/wx-config
make || return 1
+
}
package() {
+
cd ${srcdir}/${_pkgname}
make DESTDIR=${pkgdir} install
+
}