summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDavid Runge2020-11-07 00:21:57 +0100
committerDavid Runge2020-11-07 00:21:57 +0100
commit33f09e15c508d5b370aac2d42d685cb6accd64a7 (patch)
tree308086d230a43743eb5e3b3d496fd546755407b4 /PKGBUILD
downloadaur-flac123.tar.gz
Move flac123 to the AUR (FS#64585)
PKGBUILD: The flac123 upstream is basically dormant. The tool itself is not really required anymore, as there are plenty of music players capable of playing back FLAC files now (and they are still maintained).
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7c108c42c194
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: David Runge <dvzrv@archlinux.org>
+# Contributor: Alexander F Rødseth <xyproto@archlinux.org>
+# Contributor: Chris Brannon <chris@the-brannons.com>
+# Contributor: Corrado Primier <bardo@aur.archlinux.org>
+# Contributor: Patrick Burroughs <celticmadman@gmail.com>
+
+pkgname=flac123
+pkgver=0.0.12
+pkgrel=5
+pkgdesc='Command-line program for playing FLAC audio files'
+arch=('x86_64')
+license=('GPL2')
+url="https://sourceforge.net/projects/flac-tools/"
+depends=('glibc' 'popt')
+makedepends=('flac' 'libao')
+source=("https://downloads.sourceforge.net/flac-tools/${pkgname}-${pkgver}-release.tar.gz")
+sha256sums=('1976efd54a918eadd3cb10b34c77cee009e21ae56274148afa01edf32654e47d')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ autoreconf -vfi
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ depends+=('libFLAC.so' 'libao.so')
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+ install -vDm 644 {AUTHORS,BUGS,NEWS,README,README.remote,ChangeLog} \
+ -t "${pkgdir}/usr/share/doc/${pkgname}"
+}
+# vim:ts=2 sw=2 et: