summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBrian Bidulock2015-12-14 09:32:32 -0700
committerBrian Bidulock2015-12-14 09:32:32 -0700
commit94df00312c8aa78ed7eba693646c92a7e0506261 (patch)
tree563fd56cf3e25b22b4fb933a4c545f369f89dc0a /PKGBUILD
parent2f5b96af7bbe80aefe54e7571794d6256544bccb (diff)
downloadaur-fluff.tar.gz
version 1.0.3-2 (cxx11 ABI)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 15 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a563f6ce531d..ae3c302eee20 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=fluff
pkgver=1.0.3
_pkgver=1_0_3
-pkgrel=1
+pkgrel=2
pkgdesc="Fast, light file manager application for FLTK"
arch=('i686' 'x86_64')
url="https://sites.google.com/site/lockmoorecoding/downloads/fluff"
@@ -14,24 +14,24 @@ source=(https://sites.google.com/site/lockmoorecoding/downloads/$pkgname/${pkgna
md5sums=('94c4a97d31e1fe850d765a70762e0c52')
prepare() {
- cd "$srcdir"
- sed -i 's|include <Fl/|include <FL/|
- s|/usr/local/|/usr/|' fluff.cpp
- sed -i 's/gcc `fltk-config --use-images --ldflags` -lfltk_images -lm ${PROG}.o -o ${PROG}/g++ ${PROG}.o `fltk-config --use-images --ldflags` -lfltk_images -lm -o ${PROG}/' Makefile
- gendesk -n -f --pkgname=$pkgname --pkgdesc="Fast, light file manager" --categories="System;FileManager"
+ cd "$srcdir"
+ sed -i 's|include <Fl/|include <FL/|
+ s|/usr/local/|/usr/|' fluff.cpp
+ sed -i 's/gcc `fltk-config --use-images --ldflags` -lfltk_images -lm ${PROG}.o -o ${PROG}/g++ ${PROG}.o `fltk-config --use-images --ldflags` -lfltk_images -lm -o ${PROG}/' Makefile
+ gendesk -n -f --pkgname=$pkgname --pkgdesc="Fast, light file manager" --categories="System;FileManager"
}
build() {
- cd "$srcdir"
- make
+ cd "$srcdir"
+ make
}
package() {
- cd "$srcdir"
- install -Dm755 $pkgname "$pkgdir/usr/bin/$pkgname"
- install -Dm755 ${pkgname}_fc.sh "$pkgdir/usr/bin/${pkgname}_fc.sh"
- install -Dm644 ${pkgname}_help.htm "$pkgdir/usr/share/doc/fluff/${pkgname}_help.htm"
- install -Dm644 $pkgname.gif "$pkgdir/usr/share/doc/fluff/$pkgname.gif"
- install -Dm644 $pkgname.png "$pkgdir/usr/share/pixmaps/$pkgname.png"
- install -Dm644 $pkgname.desktop "$pkgdir/usr/share/applications/$pkgname.desktop"
+ cd "$srcdir"
+ install -Dm755 $pkgname "$pkgdir/usr/bin/$pkgname"
+ install -Dm755 ${pkgname}_fc.sh "$pkgdir/usr/bin/${pkgname}_fc.sh"
+ install -Dm644 ${pkgname}_help.htm "$pkgdir/usr/share/doc/fluff/${pkgname}_help.htm"
+ install -Dm644 $pkgname.gif "$pkgdir/usr/share/doc/fluff/$pkgname.gif"
+ install -Dm644 $pkgname.png "$pkgdir/usr/share/pixmaps/$pkgname.png"
+ install -Dm644 $pkgname.desktop "$pkgdir/usr/share/applications/$pkgname.desktop"
}