summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWilhelm Schuster2023-10-07 17:58:42 +0200
committerWilhelm Schuster2023-10-07 17:58:42 +0200
commit5be1fe177325a92631da545b86ceba4121de77f2 (patch)
tree10e2a9f6b57c02b9fc3edaec0faaffdbf1fcfc98 /PKGBUILD
parent5ed794aa24d67bd4f483d1384e839211d4440187 (diff)
downloadaur-fluidd-git.tar.gz
Copy build and packaging commands from official Arch package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 3 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0ddaca03272c..f7ebf740338f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Wilhelm Schuster <aur [aT] rot13 dot io>
pkgname=fluidd-git
_pkgname="${pkgname%-git}"
-pkgver=r1653.8841557a
+pkgver=r1686.35667236
pkgrel=1
pkgdesc="Klipper web frontend"
arch=(any)
@@ -28,18 +28,14 @@ build() {
cd "$srcdir/$_pkgname"
npm install --no-update-notifier --no-audit --cache "${srcdir}/npm-cache"
- ./node_modules/.bin/vite build
+ npm run build
}
package() {
cd "$srcdir/$_pkgname"
install -dm755 "${pkgdir}/usr/share/webapps"
- cp -r dist "$pkgdir/usr/share/webapps/${_pkgname}"
-
- # npm gives ownership of ALL FILES to build user
- # https://bugs.archlinux.org/task/63396
- chown -R root:root "${pkgdir}"
+ cp -dr --no-preserve=ownership dist "$pkgdir/usr/share/webapps/${_pkgname}"
install -Dm644 "${srcdir}/fluidd-klipper.cfg" "${pkgdir}/usr/share/doc/${_pkgname}/fluidd-klipper.cfg"
install -Dm644 "${srcdir}/fluidd-nginx.conf" "${pkgdir}/usr/share/doc/${_pkgname}/fluidd-nginx.conf"