summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichel Zou2024-02-26 18:32:24 +0100
committerMichel Zou2024-02-26 18:32:24 +0100
commit720be9f50191ce8e1376b733cb99caacaee8de3a (patch)
tree597e78f1bdc0e487677b4bd66cb733c534bd6761 /PKGBUILD
parente250506091f0dbd42d67426d6c42e5b8fac76c3d (diff)
downloadaur-fmilib.tar.gz
lto
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cabb480c430b..da9b41c5cb2d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,13 @@
pkgname=fmilib
pkgver=2.4.1
-pkgrel=1
+pkgrel=2
pkgdesc="open-source implementation of the FMI open standard"
arch=('x86_64')
url="http://www.jmodelica.org/FMILibrary"
-makedepends=('cmake')
-depends=('minizip' 'expat')
license=('BSD')
+makedepends=('cmake')
+depends=('glibc')
+options=(!lto)
source=("https://github.com/modelon-community/fmi-library/archive/${pkgver}.tar.gz")
sha256sums=('8199d3e9423494b714b9c4e42f055248457a7c9162df3d4652000aa9a10b8316')
@@ -23,7 +24,7 @@ prepare() {
build() {
cd "$srcdir"/fmi-library-${pkgver}
mkdir -p build && cd build
- cmake -DCMAKE_INSTALL_PREFIX=/usr ..
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DFMILIB_BUILD_TESTS=OFF ..
make
}