summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichael Lass2016-01-30 11:39:17 +0100
committerMichael Lass2016-01-30 11:48:28 +0100
commit05bb0518352242a6a687efae1f5b24dceff7cbbf (patch)
tree5fcc76d48522cde6537789fa017c4afaebafb645 /PKGBUILD
parentd92838964f2e4e9dacb0656c1fa962a975a8fc95 (diff)
downloadaur-05bb0518352242a6a687efae1f5b24dceff7cbbf.tar.gz
Connect .fzz files to fritzing
Thanks to razer who suggested this change. Also adjust the dependencies again. libsm and libxkbcommon-x11 are now directly required by qt5-base.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 11 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ddc2053d8d72..a9bb55455554 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,19 +7,21 @@
pkgname=fritzing
pkgver=0.9.2b
-pkgrel=1
+pkgrel=2
partsrev=de7f8a4c8f7df4ed57386edf68275cdd66a1910d
pkgdesc='PCB layout prototyping application'
arch=('i686' 'x86_64')
url=http://fritzing.org
license=(GPL3)
makedepends=('boost')
-# libsm and libxkbcommon-x11 are optdepends for qt5-base that are needed for the xcb plugin used by Fritzing
-depends=('java-environment' 'libsm' 'libxkbcommon-x11' 'python2' 'qt5-serialport' 'qt5-svg')
+install=fritzing.install
+depends=('desktop-file-utils' 'java-environment' 'python2' 'qt5-serialport' 'qt5-svg' 'shared-mime-info')
source=(https://github.com/fritzing/fritzing-app/archive/${pkgver}.tar.gz
- https://github.com/fritzing/fritzing-parts/archive/${partsrev}.tar.gz)
+ https://github.com/fritzing/fritzing-parts/archive/${partsrev}.tar.gz
+ fritzing.xml)
sha256sums=('6e9dbb94a4ca5e23effc2056f471c78913b9efa4c154ced94de8f72bfe29735f'
- 'b9eeac2d8b169eb80162f607b5bedd9a2c92191690685955d674c14ba7aefcc1')
+ 'b9eeac2d8b169eb80162f607b5bedd9a2c92191690685955d674c14ba7aefcc1'
+ '9aa55c4a27025b40a1573b3b09a59f48709dfa5ac637ef6a059fd8157d20192b')
prepare() {
mv "$srcdir"/fritzing-parts-${partsrev}/* "$srcdir"/fritzing-app-${pkgver}/parts
@@ -41,4 +43,8 @@ package() {
-name \*.py -exec sed -i \
-e 's#/usr/bin/env python$#/usr/bin/env python2#' \
-e 's#/usr/bin/python$#/usr/bin/python2#' {} \;
+
+ # connect .fzz files to fritzing by default
+ install -Dm644 "${srcdir}/fritzing.xml" "${pkgdir}/usr/share/mime/packages/fritzing.xml"
+ echo "MimeType=application/x-fritzing;" >> "${pkgdir}/usr/share/applications/fritzing.desktop"
}