summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTobias Bachmann2024-03-28 19:24:57 +0100
committerTobias Bachmann2024-03-28 19:24:57 +0100
commit3b54f78bc6ea27adc57eb4e776c5e1be06103cc5 (patch)
tree2bf614e77e7a90e1944b8544b86dd928a8f3becc /PKGBUILD
parent30d9ff8b4972923a75ecae9d95d4824a2bf931cf (diff)
downloadaur-fslpy.tar.gz
Version bump
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 89cb3fbc372e..47bcda80ee70 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Tobias Bachmann <tobachmann@gmx.de>
pkgname=fslpy
-pkgver=3.16.1
+pkgver=3.18.1
pkgrel=1
pkgdesc="fslpy is the python library collection used by FSL and related projects"
arch=('any')
@@ -8,14 +8,14 @@ url="https://fsl.fmrib.ox.ac.uk/fsl/fslwiki/FSLeyes"
license=('Apache')
groups=()
# Keep python-deprecated to keep FEAT check of FSL FEEDS from failing
-depends=('python' 'python-six' 'python-numpy' 'python-scipy' 'python-nibabel' 'python-h5py' 'python-deprecation' 'python-dataclasses')
+depends=('python' 'python-numpy' 'python-scipy' 'python-nibabel' 'python-h5py' 'python-dill')
makedepends=('python-setuptools' 'python-build' 'python-installer' 'python-wheel')
-optdepends=('python-rtree' 'python-pillow')
+optdepends=('python-rtree' 'python-pillow' 'python-indexed-gzip' 'python-trimesh')
provides=()
conflicts=()
replaces=()
source=(https://git.fmrib.ox.ac.uk/fsl/${pkgname}/-/archive/${pkgver}/${pkgname}-${pkgver}.tar.gz)
-sha256sums=('b6eb9b0355ed0b430ca04f6d56da82ec3d4a73f94a7e68905cd9ac31d0f6142d')
+sha256sums=('961e0749fce6ecf0d28abf8ca0544a1df476c2d595b2dcec01f488ebe83f75a0')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"