summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorthatmadhacker2019-06-19 14:21:08 -0400
committerthatmadhacker2019-06-19 14:21:08 -0400
commita7e98b1dd1adc5c06926e29a6eca6dc39c413885 (patch)
treeea8db63b7d6cb66795af8506b78e32aa3645e5c0 /PKGBUILD
downloadaur-fspm.tar.gz
added pkgbuild and srcinfo
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..61c970facb40
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Finlay Maroney finman292004@protonmail.com
+pkgname=fspm
+pkgver=1.0
+pkgrel=1
+pkgdesc="The FinlayScript6 Package Manager"
+arch=('any')
+url=""
+license=('MIT')
+groups=()
+depends=('java-runtime' 'bash')
+makedepends=(git)
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("git://github.com/thatmadhacker/FSPM.git")
+noextract=()
+md5sums=("SKIP")
+
+build() {
+ cd "FSPM"
+
+ ./gradlew build
+}
+
+package() {
+ mkdir -p "../pkg/fspm/usr/lib/FS6/bin"
+ mkdir -p "../pkg/fspm/usr/bin"
+ cp "FSPM/build/libs/FSPM-all.jar" "../pkg/fspm/usr/lib/FS6/bin/FSPM.jar"
+ cp "FSPM/fspm" "../pkg/fspm/usr/bin/"
+ cd ../pkg/
+ chmod +x "fspm/usr/lib/FS6/bin/FSPM.jar"
+ chmod +x "fspm/usr/bin/fspm"
+}