summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHyacinthe Cartiaux2018-03-28 11:30:51 +0200
committerHyacinthe Cartiaux2018-03-28 11:30:51 +0200
commita57dede64832b8ee601c2096cad461b2ea5f18ea (patch)
treece01deb64cf2df4086e0a77b497e02d438e7e325 /PKGBUILD
parent892403ce8b5b0bdafe0bb6c30f58d07d844c3b0f (diff)
downloadaur-funny-manpages.tar.gz
Update to 2.3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 7 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5ad65a070792..039ec15e61ae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,24 +3,18 @@
# Contributor: StaCk <proc.null at gmail dot com>
pkgname=funny-manpages
-pkgver=1.3
-pkgrel=7
+pkgver=2.3
+pkgrel=1
pkgdesc="A set of miscellaneous humorous manpages (don't take them too seriously!)."
arch=('any')
url="http://debian.org/"
license=('custom')
-source=(http://httpredir.debian.org/debian/pool/main/f/$pkgname/${pkgname}_$pkgver.orig.tar.gz
- http://httpredir.debian.org/debian/pool/main/f/$pkgname/${pkgname}_$pkgver-5.diff.gz)
-sha256sums=('5dcfcbb30a26585b53f27dc591b7e9cd485f738e603fa3fc9f074c55eabb6f91'
- 'aea8369726213a8294f70c0d0b1637b2cf961d6208ad52fa97daf105e9452a53')
+source=("https://github.com/ltworf/${pkgname}/releases/download/${pkgver}/${pkgname}_${pkgver}.orig.tar.gz")
+sha512sums=('7920e9a62972f8ea0649b50d0b108936a6e0a5d5b68baccadded4999d0219af3f4685349dd881aded9e762e0d1f00575f382d155db0969f7e51a4a1963f0519e')
build() {
- # Apply the patch
- cd $srcdir
- patch -p0 -i ${pkgname}_$pkgver-5.diff || return 1
-
# Rename the manpages to man6
- cd $pkgname-$pkgver.orig
+ cd $srcdir/$pkgname/man
for f in *.[0-57-9]fun ; do
mv $f ${f/.?fun/.6fun}
done
@@ -28,8 +22,8 @@ build() {
package() {
install -d $pkgdir/usr/share/man/man6/
- install -m 644 $srcdir/$pkgname-$pkgver.orig/*.6fun $pkgdir/usr/share/man/man6/
+ install -m 644 $srcdir/$pkgname/man/*.6fun $pkgdir/usr/share/man/man6/
# Install the license
- install -Dm 644 $srcdir/$pkgname-$pkgver.orig/debian/copyright $pkgdir/usr/share/licenses/$pkgname/copyright
+ install -Dm 644 $srcdir/$pkgname/LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
}