summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMirco Tischler2017-02-11 15:07:29 +0100
committerMirco Tischler2017-02-11 15:07:29 +0100
commit9714fe0477236e6340455662dfeac168791951f3 (patch)
tree5e5a711f260a39836d165e774ab15a4e7f6d70d8 /PKGBUILD
parent5d7990db4f1b7b340be43b48eff37490af7f0ab5 (diff)
downloadaur-9714fe0477236e6340455662dfeac168791951f3.tar.gz
fwupdate: 0.8-2: add post install instructions and move EFI executable to better path.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 078ef961cbe4..2fafc0b037a1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=fwupdate
pkgver=8
-pkgrel=1
+pkgrel=2
pkgdesc='Tools for using the ESRT and UpdateCapsule() to apply firmware updates'
arch=('i686' 'x86_64')
url='https://github.com/rhinstaller/fwupdate'
@@ -11,17 +11,20 @@ depends=('efivar' 'libsmbios' 'bash')
makedepends=('pesign' 'gnu-efi-libs')
source=("${url}/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.bz2")
sha256sums=('c8120f6ff0378d0f070373b6d46bfcaee18deeaf5a50c65d596c6df866980883')
+install=fwupdate.install
+
+_efidir=arch
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
- make EFIDIR=/usr/lib GNUEFIDIR=/usr/lib
+ make EFIDIR="${_efidir}" GNUEFIDIR=/usr/lib
}
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
- make LIBDIR=/usr/lib EFIDIR=/usr/lib DESTDIR="${pkgdir}" libexecdir=/usr/lib/ install
+ make LIBDIR=/usr/lib EFIDIR="${_efidir}" DESTDIR="${pkgdir}" libexecdir=/usr/lib/ install
#don't install into /boot. copy files to /usr/lib/fwupdate for manual installation
install -d ${pkgdir}/usr/lib/fwupdate