summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRoyce Fan2020-07-23 23:11:32 +0800
committerRoyce Fan2020-07-23 23:11:32 +0800
commit8924e232d66474a5252e4c483728651e923bcc45 (patch)
treefa2509cd25f64bb64edd900b251dd25dcc7f1139 /PKGBUILD
downloadaur-g3log.tar.gz
First upload to aur
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f97511718c51
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Royce Fan <fchunhuei@gmail.com>
+
+pkgname=g3log
+pkgver=1.3.3
+pkgrel=1
+pkgdesc="An open-source C++ asynchronous logger with dynamic sinks"
+arch=('x86_64')
+url="https://github.com/KjellKod/g3log"
+license=('Unlicense')
+depends=()
+makedepends=('cmake' 'gtest')
+source=("https://github.com/KjellKod/$pkgname/archive/$pkgver.tar.gz")
+sha256sums=('d8cae14e1508490145d710f10178b2da9b86ce03fb2428a684fff35576fe5d5c')
+
+build() {
+ cd "$pkgname-$pkgver"
+ mkdir _build
+ cmake . -B _build
+ # cmake . -DADD_G3LOG_UNIT_TEST=ON -B _build
+ cmake --build _build
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ # cmake --build _build --target test
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ cmake --build _build --target install -- DESTDIR="$pkgdir/"
+}