summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFabioLolix2023-04-12 23:31:27 +0200
committerFabioLolix2023-04-12 23:31:27 +0200
commitaeffc01631b05cef54e7ffcfc44cbe5d5a686390 (patch)
treeb32881d0e2f9b47617b8c68870eae0097e395a3e /PKGBUILD
parent92adc37d70ce2fb30f447451ec4214b39352a7df (diff)
downloadaur-gamehub-git.tar.gz
add proton patch
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 11 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f5e9ae640bdf..c325e01edb27 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,8 @@
# Contributor: Helder Bertoldo <helder.bertoldo@gmail.com>
pkgname=gamehub-git
-pkgver=0.16.3.4.dev.r0.g9952b8f
-pkgrel=1
+pkgver=0.16.3.6.dev.r1.gfaf18ae
+pkgrel=2
pkgdesc="Games manager, downloader, library that supports GOG, Steam and Humble Bundle"
arch=(i686 x86_64 armv6h armv7h aarch64)
url="https://tkashkin.github.io/projects/gamehub/"
@@ -16,14 +16,21 @@ makedepends=(git meson ninja vala)
provides=(gamehub)
conflicts=(gamehub)
options=(!strip debug)
-source=("git+https://github.com/tkashkin/GameHub.git#branch=dev")
-sha256sums=('SKIP')
+source=("git+https://github.com/tkashkin/GameHub.git#branch=dev"
+ "https://raw.githubusercontent.com/FabioLolix/AUR-artifacts/master/gamehub-protonfix.patch")
+sha256sums=('SKIP'
+ '26e267dade0b416699707a8612aa4f1c32b60a08889c217127ddf1843b7302ba')
pkgver() {
cd "GameHub"
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ cd "GameHub"
+ patch -Np1 -i ../gamehub-protonfix.patch
+}
+
build() {
cd "GameHub"
#CFLAGS="$CFLAGS -O0" meson . build --prefix=/usr -Ddistro=arch --buildtype=debug