summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristopher Arndt2020-04-16 13:12:01 +0200
committerChristopher Arndt2020-04-16 13:12:01 +0200
commit5eb4a0ec235307fd382f4b60975f194cb251fd34 (patch)
tree72d273806cf9e4561c9f81f6053afab715a86f51 /PKGBUILD
parent612ad053a522184b3c0a045631e30c4d099daf44 (diff)
downloadaur-ganv-git.tar.gz
Various fixes (requires clan build)
* Switch project and sources URLs to HTTPS * README was renamed to README.md * Add *.zst binary package to git ignore
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 7 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 478d8f778cfc..2e1ab9463637 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,19 +3,19 @@
_pkgname=ganv
pkgname="${_pkgname}-git"
-pkgver=1.5.4.r348.8b3520b
+pkgver=1.6.0.r354.662bcbc
pkgrel=1
pkgdesc="An interactive Gtkmm canvas widget for graph-based interfaces (git version)"
arch=('i686' 'x86_64')
-url="http://drobilla.net/software/ganv/"
+url="https://drobilla.net/software/ganv/"
license=('GPL3')
-depends=('atk' 'cairo' 'fontconfig' 'gcc-libs' 'gdk-pixbuf2' 'glib2' 'glibc' 'glibmm' 'graphviz' 'gtk2' 'gtkmm'
-'libfreetype.so' 'pango')
+depends=('atk' 'cairo' 'fontconfig' 'gcc-libs' 'gdk-pixbuf2' 'glib2' 'glibc' 'glibmm'
+ 'graphviz' 'gtk2' 'gtkmm' 'libfreetype.so' 'pango')
makedepends=('git' 'python')
provides=("$_pkgname" "$_pkgname=${pkgver//.r*/}" "lib${_pkgname}-${pkgver::1}.so")
conflicts=("$_pkgname")
-source=("${_pkgname}::git+http://gitlab.com/drobilla/${_pkgname}.git"
- 'autowaf::git+http://gitlab.com/drobilla/autowaf.git')
+source=("${_pkgname}::git+https://gitlab.com/drobilla/${_pkgname}.git"
+ 'autowaf::git+https://gitlab.com/drobilla/autowaf.git')
sha256sums=('SKIP'
'SKIP')
@@ -49,6 +49,5 @@ package() {
cd "$srcdir/${_pkgname}"
python waf install --destdir=${pkgdir}
- install -vDm 644 {AUTHORS,NEWS,README} \
- -t "${pkgdir}/usr/share/doc/${pkgname}/"
+ install -vDm 644 AUTHORS NEWS README.md -t "${pkgdir}/usr/share/doc/${pkgname}/"
}