summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHuayu Zhang2022-07-11 23:46:41 +0100
committerHuayu Zhang2022-07-11 23:46:41 +0100
commit0f4a872fb6941d085946e301b4ceecb34cf3d6a3 (patch)
tree5f35a43eb2dfc05c8b537f803ec57be646ec5057 /PKGBUILD
parentf5783dd2e755b1eeba1dcac49a91b32c8905f2fe (diff)
downloadaur-gcc-11.tar.gz
1. The make flag has been removed. For people who wants to speed of your makepkg process, please refer to "https://wiki.archlinux.org/title/Makepkg#Parallel_compilation"
2. Now the source archive is signed by GNU gpg keyring ("https://ftp.gnu.org/gnu/gnu-keyring.gpg") 3. This pkgbuild is for clion remote debug (cause the version of gcc11 is too "new") as described in "Description". So, this package will be updated by following the clion remote debug supported version. 4. "checkdepends" simply removed 5. "git" has been removed from makedepends
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 10 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 71f6fc4b4be4..cf566998e7cf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,12 +13,11 @@ pkgdesc='The GNU Compiler Collection (version 11.1.0) for remote debugging compa
arch=(x86_64)
license=(GPL LGPL FDL custom)
url='https://gcc.gnu.org'
-#makedepends=(binutils doxygen git libmpc python)
-makedepends=(binutils git libmpc python)
-checkdepends=(dejagnu inetutils)
-#options=(!emptydirs !lto)
-source=(https://sourceware.org/pub/gcc/releases/gcc-${pkgver}/gcc-${pkgver}.tar.xz)
-sha256sums=("4c4a6fb8a8396059241c2e674b85b351c26a5d678274007f076957afa1cc9ddf")
+makedepends=(binutils libmpc python)
+source=(https://sourceware.org/pub/gcc/releases/gcc-${pkgver}/gcc-${pkgver}.tar.xz{,.sig})
+# import GNU Keyrings from "https://ftp.gnu.org/gnu/gnu-keyring.gpg" first!!!
+validpgpkeys=(D3A93CAD751C2AF4F8C7AD516C35B99309B5FA62) # Jakub Jelinek <jakub@redhat.com>
+sha256sums=("4c4a6fb8a8396059241c2e674b85b351c26a5d678274007f076957afa1cc9ddf" "30ddb74a7dc144917ece0053e8cd0a18d6d0390941257925e0c70eb88a52e629")
_ins_path=/opt/gcc-11
build() {
@@ -47,7 +46,11 @@ build() {
--disable-build-format-warnings \
--disable-werror
- make -j$(nproc)
+ make
+ # if you want to speed up your makepkg please go to /etc/makepkg.conf and add line of:
+ # MAKEFLAGS="-j$(nproc)"
+
+ # make -j$(nproc)
# make -j$(nproc) all-target-libgcc
}