summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChris Severance2016-06-07 11:59:01 -0400
committerChris Severance2016-06-07 11:59:01 -0400
commita1a028d18afc027699a9e25bbbee1a6ac2297917 (patch)
tree86a20c83fa8b27d298a237020464ddf3c200b66e /PKGBUILD
parenta8a9397a5e4276e87cfb6ed0d778d44c8725fda9 (diff)
downloadaur-a1a028d18afc027699a9e25bbbee1a6ac2297917.tar.gz
Fix x64 compile
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e986f324c921..7229da50080a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -36,7 +36,7 @@ prepare() {
patch -Np0 -i "${srcdir}/gcc-hash-style-both.patch"
case "${CARCH}" in
- 'x86_64') patch -Np1 -i "${srcdir}/gcc_pure64.patch"; false;;
+ 'x86_64') patch -Np1 -i "${srcdir}/gcc_pure64.patch";;
esac
echo "${pkgver}" > 'gcc/BASE-VER'
@@ -48,6 +48,7 @@ prepare() {
cd 'build'
../configure \
+ --build="${CHOST}" \
--prefix='/usr' \
--mandir='/usr/share/man' \
--infodir='/usr/share/info' \
@@ -73,7 +74,7 @@ prepare() {
build() {
set -u
- cd "gcc-${pkgver}"
+ cd "gcc-${pkgver}/build"
local _nproc="$(nproc)"; _nproc=$((_nproc>8?8:_nproc))
make -j "${_nproc}"
set +u