summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorcaltlgin2020-10-03 16:00:15 +1300
committercaltlgin2020-10-03 16:00:15 +1300
commitafa1b6de0ba551134ae6fa55b682442716eac227 (patch)
treeedfbc9050e7e42edd45120445d4c5bc4f2aeb38b /PKGBUILD
downloadaur-gcron-git.tar.gz
Add to AUR
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..015aed86db60
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+
+_pkgname='gcron'
+pkgname="${_pkgname}-git"
+pkgver=1.0.5.r5.g36b830c
+pkgrel=1
+pkgdesc='Manage and understand your cron configuration with ease'
+arch=('x86_64')
+url='https://github.com/padjis/gcron'
+license=('GPL3')
+depends=('granite')
+makedepends=('git' 'meson' 'vala')
+provides=("${_pkgname}")
+source=("git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ git -C "${_pkgname}" describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ arch-meson "${_pkgname}" build
+ meson compile -C build
+}
+
+package() {
+ DESTDIR="${pkgdir}" meson install -C build
+ install -Dm644 -t "${pkgdir}/usr/share/doc/${_pkgname}" "${_pkgname}/README.md"
+}
+
+# vim: ts=2 sw=2 et: