summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTony Lambiris2021-10-08 00:19:06 -0400
committerTony Lambiris2021-10-08 00:19:06 -0400
commit68940f49c998473bc73cd0dace7437faddf64a03 (patch)
treede2ee40584993398ee78a157eee57981b07f1141 /PKGBUILD
parente48eac76adc3f80054c4fb2b0addb32a231fb2f8 (diff)
downloadaur-gdtoa-desktop-git.tar.gz
Version bump
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 10 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 457e869c572c..3520f3b84284 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
-# Maintainer: Tony Lambiris <tony@criticalstack.com>
+# Maintainer: Tony Lambiris <tony@libpcap.net>
pkgname=gdtoa-desktop-git
-pkgver=r22.96aac69
+pkgver=r30.698924a
pkgrel=1
pkgdesc="Binary-decimal floating-point conversion library by David M. Gay"
arch=('i686' 'x86_64')
@@ -20,12 +20,16 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-build() {
+prepare() {
cd "${srcdir}/${pkgname}"
mkdir -p build
- cd build
+}
+build() {
+ cd "${srcdir}/${pkgname}"
+
+ cd build
cmake .. -Wno-dev \
-DCMAKE_VERBOSE_MAKEFILE=ON \
-DCMAKE_INSTALL_PREFIX=/usr \
@@ -34,8 +38,9 @@ build() {
}
package() {
- cd "${srcdir}/${pkgname}/build"
+ cd "${srcdir}/${pkgname}"
+ cd build
make DESTDIR="${pkgdir}" install
if test -d "${pkgdir}"/usr/lib64; then