diff options
author | Filippo Falezza | 2023-03-15 14:33:33 +0000 |
---|---|---|
committer | Filippo Falezza | 2023-03-15 14:33:33 +0000 |
commit | e83fda1986f618510867393208c7fbddf80a3ade (patch) | |
tree | 3538a0e02e76fba071c3efafe976866ee11fd0d0 /PKGBUILD | |
parent | 121dd4017f994f35e2b4ed53409e0b74ea6f5d13 (diff) | |
download | aur-geant4-lend.tar.gz |
Added csh support
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 8 |
1 files changed, 5 insertions, 3 deletions
@@ -2,7 +2,7 @@ pkgname='geant4-lend' pkgver=1.3 -pkgrel=2 +pkgrel=3 pkgdesc="Low Energy Nuclear Data (LEND) for Geant4" optdepends=('geant4') url="http://geant4.cern.ch/" @@ -13,12 +13,14 @@ sha256sums=('2b239f592b24cdf862b0505b762cf98e418e999223d9dcebcb4c613026a5ee0c') build() { cd $srcdir - echo "export G4LENDDATA=/opt/Geant4/Libraries/LEND_GND1.3_ENDF.BVII.1" > LEND.sh + echo "export G4LENDDATA=/opt/Geant4/Libraries/LEND_GND${pkgver}_ENDF.BVII.1" > LEND.sh + echo "setenv G4LENDDATA /opt/Geant4/Libraries/LEND_GND${pkgver}_ENDF.BVII.1" > LEND.csh } package() { cd $srcdir - install -D -m644 LEND.sh $pkgdir/etc/profile.d/LEND.sh + install -D -m755 LEND.sh $pkgdir/etc/profile.d/LEND.sh + install -D -m755 LEND.csh $pkgdir/etc/profile.d/LEND.csh find LEND_GND1.3_ENDF.BVII.1 -type f -exec install -D "{}" "$pkgdir/opt/Geant4/Libraries/{}" \; } |