summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorABelliqueux2022-02-07 13:24:56 +0100
committerABelliqueux2022-02-07 13:24:56 +0100
commitcda8528c0ac3e15b654a7389b572438946335f41 (patch)
tree6ae0f5e567cbc10f2368ea25ca66661e59778bef /PKGBUILD
parent0d7754131426d57d0a242b2b6b4d9319b76253e0 (diff)
downloadaur-gendev.tar.gz
Update to 0.7.1, use liblto.so
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 14 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a80ac07558e6..c71e23a25d4f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,23 @@
-# Maintainer: Vinicius Correa <vinicius dot correa at zoho dot com>
+# Maintainer: Arthus Belliqueux <contact at arthus dot net>
+# Contributor: Vinicius Correa <vinicius dot correa at zoho dot com>
pkgname=gendev
-pkgver=0.4.0
-pkgrel=2
+pkgver=0.7.1
+pkgrel=1
pkgdesc="Genesis development environment for Linux"
arch=('any')
url="https://github.com/kubilus1/${pkgname}"
license=('BSD')
-depends=('texinfo' 'jdk8-openjdk')
+depends=('texinfo' 'jdk8-openjdk' 'llvm-libs')
options=(!strip)
-makedepends=('')
-optdepends=('')
-source=("https://github.com/kubilus1/gendev/releases/download/${pkgver}/${pkgname}_${pkgver}.txz")
-md5sums=('37e61b25baa4229aa6b6c3d79d7b7953')
+makedepends=()
+optdepends=()
+source=("https://github.com/kubilus1/gendev/releases/download/${pkgver}/${pkgname}_${pkgver}.txz" "liblto.patch")
+md5sums=('08f79f377570871899472ef4503382d3'
+ '68a2b31d51b80cb009b10443f527c2ba')
+
+prepare() {
+ patch --binary --strip=1 --input=liblto.patch
+}
package() {
install -dm755 "${pkgdir}/opt"