summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBioArchLinuxBot2022-04-17 21:51:50 +0000
committerBioArchLinuxBot2022-04-17 21:51:50 +0000
commit3e29535ccfec717d6387d40adda3420f0ccea6e1 (patch)
tree228250e6afedd594e4ae2b93ccc8389e675e20d2 /PKGBUILD
parentc6e80af7197dd082a90b3b067d6b3dd061f3cc2d (diff)
downloadaur-gffcompare.tar.gz
[lilac] updated to 0.12.6-2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 10 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f6efd6e9df6d..b265a19451f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,24 @@
# Maintainer: Guoyi
pkgname=gffcompare
pkgver=0.12.6
-pkgrel=1
+pkgrel=2
pkgdesc="classify, merge, tracking and annotation of GFF files by comparing to a reference annotation GFF"
arch=('x86_64')
url="https://github.com/gpertea/gffcompare"
license=('MIT')
depends=()
-makedepends=('make')
+makedepends=('make' 'git')
optdepends=()
source=(https://github.com/gpertea/gffcompare/archive/refs/tags/v${pkgver}.tar.gz)
sha256sums=('4e01344c533987a0a8227bfcca9d180504c1a1392aa343e1f6b0752341e712cf')
+prepare(){
+ cd $srcdir
+ git clone https://github.com/gpertea/gclib.git
+}
+build(){
+ cd $srcdir/gclib
+ make
+}
build() {
cd "${pkgname}"-$pkgver
make release