summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVicente Bergas2015-12-20 19:04:55 +0100
committerVicente Bergas2015-12-20 19:04:55 +0100
commitf770b52b4a8796bbf7b8b30788c7dc436689d630 (patch)
tree88b8a7999215fbd06b888e59f664f5fccae03098 /PKGBUILD
parent31c48adc966b534a14b4f034eb86a6392b9df773 (diff)
downloadaur-f770b52b4a8796bbf7b8b30788c7dc436689d630.tar.gz
Update to 0.33-2
Use new GitHub repository.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4f4d11303149..35468836d6c3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=ghdl
pkgver=0.33
-pkgrel=1
+pkgrel=2
arch=('i686' 'x86_64')
pkgdesc='VHDL simulator'
url='http://sourceforge.net/projects/ghdl-updates/'
@@ -14,10 +14,8 @@ _gccver=4.9.3
_islver=0.12.2
_cloogver=0.18.1
-# "tag=ghdl-0.33" refers to the 0.33 branch, not a fixed and released version.
source=(
- #"ghdl::hg+http://hg.code.sf.net/p/ghdl-updates/code#tag=ghdl-${pkgver}_release"
- "ghdl::hg+http://hg.code.sf.net/p/ghdl-updates/code#revision=900"
+ "git://github.com/tgingold/ghdl#tag=v${pkgver}"
"ftp://ftp.gnu.org/gnu/gcc/gcc-${_gccver}/gcc-${_gccver}.tar.bz2"
"http://isl.gforge.inria.fr/isl-${_islver}.tar.bz2"
"http://www.bastoul.net/cloog/pages/download/cloog-${_cloogver}.tar.gz"
@@ -35,6 +33,7 @@ prepare() {
make copy-sources
cd "${srcdir}/gcc-${_gccver}"
+
# link isl/cloog for in-tree builds
ln -s ../isl-${_islver} isl
ln -s ../cloog-${_cloogver} cloog
@@ -44,14 +43,16 @@ prepare() {
# Arch Linux installs x86_64 libraries /lib
[[ $CARCH == "x86_64" ]] && sed -i '/m64=/s/lib64/lib/' gcc/config/i386/t-linux64
+
+ # hack! - some configure tests for header files using "$CPP $CPPFLAGS"
+ sed -i "/ac_cpp=/s/\$CPPFLAGS/\$CPPFLAGS -O2/" {libiberty,gcc}/configure
+
+ mkdir ${srcdir}/gcc-build
}
build() {
- mkdir "${srcdir}/gcc-build"
cd "${srcdir}/gcc-build"
- CPPFLAGS=${CPPFLAGS/-D_FORTIFY_SOURCE=2/}
-
# using -pipe causes spurious test-suite failures
# http://gcc.gnu.org/bugzilla/show_bug.cgi?id=48565
CFLAGS=${CFLAGS/-pipe/}