summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAdrien Prost-Boucle2019-09-25 08:38:01 +0200
committerAdrien Prost-Boucle2019-09-25 08:38:01 +0200
commit5cdf0447fba4ccef14e988a62224679da2d61b8d (patch)
treecb6d1feb1ed975a0433efe39637a75e5d0c9321e /PKGBUILD
parenta7da6cade79937c8e8fd47afdc59c4bd4e56c676 (diff)
downloadaur-5cdf0447fba4ccef14e988a62224679da2d61b8d.tar.gz
Remove deprecated commands, add symlink to main lib
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 12 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2caf21d6ca05..109efdaee5ff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Adrien Prost-Boucle <adrien.prost-boucle@laposte.net>
pkgname=ghdl-mcode-git
-pkgver=0.37dev.git20190907
+pkgver=0.37dev.git20190925
pkgrel=1
arch=('i686' 'x86_64')
pkgdesc='VHDL simulator - mcode back-end'
@@ -33,7 +33,11 @@ pkgver() {
build() {
cd "${srcdir}/ghdl"
- ./configure --prefix=/usr/ --enable-synth
+ # Note : Add --enable-openieee to use free (but not complete) implementation of IEEE VHDL libs
+ ./configure \
+ --prefix=/usr/ \
+ --enable-libghdl \
+ --enable-synth
make
@@ -43,7 +47,11 @@ package() {
cd "${srcdir}/ghdl"
make DESTDIR="${pkgdir}" install
- # Install library for synthesis
- make DESTDIR="${pkgdir}" install.libghdlsynth
+
+ # In case it does not exist, create symlink libghdl.so
+ local _gso=`ls "${pkgdir}/usr/lib/" | grep -e '^libghdl-.*\.so$' | head -n 1`
+ if [[ -n "$_gso" ]] ; then
+ ln -s "$_gso" "${pkgdir}/usr/lib/libghdl.so"
+ fi
}