summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEthan Kerrick2024-02-27 10:26:21 -0500
committerEthan Kerrick2024-02-27 10:26:21 -0500
commit3f983ce0cf2f4bf28b0e2c660fabe6bc5f75bdab (patch)
tree6b9e796017d2d93dcc79d32dc5890c1ff42dc19b /PKGBUILD
parentba6a8e718f8139b761719b0e34b70a8007e3ec64 (diff)
downloadaur-giada.tar.gz
updated to 1.0.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6443e53d7b0e..3274afe151ba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,12 +4,12 @@
# NOTE: can currently not be built using devtools:
# https://github.com/monocasual/giada/issues/553
pkgname=giada
-pkgver=0.26.1
+pkgver=1.0.0
pkgrel=1
pkgdesc="A free, minimal, hardcore audio tool for DJs, live performers and electronic musicians"
arch=(x86_64)
url="https://www.giadamusic.com/"
-license=(GPL3)
+license=(GPL-3.0-or-later)
groups=(pro-audio)
depends=(gcc-libs glibc hicolor-icon-theme libx11 libxcursor libxft libxinerama libxpm fmt libsm libxrender libxext libxfixes fontconfig libice python libxrandr)
options=(!buildflags !makeflags)
@@ -27,11 +27,11 @@ source=(
"git+https://github.com/monocasual/geompp.git#commit=dd75643"
-"git+https://github.com/monocasual/mcl-audio-buffer.git#commit=d641e3e"
+"git+https://github.com/monocasual/mcl-audio-buffer.git#commit=92a8386"
"git+https://github.com/monocasual/mcl-atomic-swapper.git#commit=459d45d"
-"git+https://github.com/fltk/fltk.git#commit=06d1289"
+"git+https://github.com/fltk/fltk.git#commit=d963dde"
"git+https://github.com/cameron314/concurrentqueue.git#commit=bf1fe24"
)
@@ -77,7 +77,7 @@ package() {
make DESTDIR="$pkgdir/" install -C build
cd "$pkgname-$pkgver/"
install -vDm 644 {ChangeLog,README.md} -t "${pkgdir}/usr/share/doc/${pkgname}"
- rm -rv "${pkgdir}/usr/include/"
- rm -rv "${pkgdir}/usr/lib/"
- rm -rv "${pkgdir}/usr/bin/JUCE-7.0.5"
+ rm -rv "${pkgdir}/usr/include/"
+ rm -rv "${pkgdir}/usr/lib/"
+ rm -rv "${pkgdir}/usr/bin/JUCE-7.0.5"
}