summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorElMastro2017-08-03 01:20:13 +0200
committerElMastro2017-08-03 01:20:13 +0200
commit4ffb8b9b9484dca72b3c31dd3ab1ce05020e9b8a (patch)
tree017dbf03f52cdad7b9b8b457bb5e063a5c9ec552 /PKGBUILD
parent64a8197bb26cc66cfa78cdc30bf753c8618dcd7c (diff)
downloadaur-4ffb8b9b9484dca72b3c31dd3ab1ce05020e9b8a.tar.gz
Working Again, thanks to gymka
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 11 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f8cd93db9c56..c861fb270d08 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,28 @@
#Maintainer: M. Mastroeni <the_maxtro@hotmail.it>
pkgname=gimp-gap
-pkgver=2.6.0
-pkgrel=5
+pkgver=2.6.1
+pkgrel=1
pkgdesc="Gimp Animation Package, gimp's plugin for animation"
url="https://www.gimp.org/tutorials/Using_GAP/"
arch=('x86_64' 'i686')
-license=('GPLv3')
+license=('GPLv3' )
depends=('gimp>=2.6.0' 'glib2')
-makedepends=('intltool')
+makedepends=( 'intltool')
optdepends=('xvidcore: compression codec'
'lbzip2: data compressor'
'faac: audio encoder'
'faad2: audio decoder'
'lame: mpeg layer 3 codec'
'libx264: H264 codec')
-source=("http://download.gimp.org/pub/gimp/plug-ins/v2.6/gap/${pkgname}-${pkgver}.tar.bz2")
-md5sums=('249ed829de8b78675c0fe4ef4212089f')
-
+md5sums=()
+_gitroot="https://github.com/GNOME/gimp-gap"
+_gitname=""
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- ./configure CC="gcc" CXX="g++" LDFLAGS="-lm" CFLAGS="-g"
+ git clone ${_gitroot}
+ cd "${srcdir}/gimp-gap"
+ ./autogen.sh CC="gcc" CXX="g++" LDFLAGS="-lm" CFLAGS="-g"
cmake
make
- make DESTDIR="${pkgdir}" install
+ make DESTDIR="${pkgdir}" install
}