summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorYounes Khoudli2024-01-19 12:53:04 +0100
committerYounes Khoudli2024-01-19 12:53:04 +0100
commit5cba4002e3cbb0e518f1a5ce0905b31186a6bee2 (patch)
tree632ee4a6c0ef94abe0aa7022437b1637474cc13a /PKGBUILD
parentc95079b160cbe8f832c3a38de858686610438f39 (diff)
downloadaur-git-pw.tar.gz
Update to release 2.6.0, use python-build
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 10 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ef24a78b5da7..1de9ba874e54 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Maxime "pep" Buquet <archlinux@bouah.net>
_pkgname=git-pw
-_tag=2.5.0
+_tag=2.6.0
pkgname=${_pkgname}
pkgver=${_tag}
pkgrel=1
@@ -12,6 +12,7 @@ license=('MIT')
arch=('any')
depends=(
'git'
+ 'python'
'python-requests'
'python-click'
'python-pbr'
@@ -19,13 +20,18 @@ depends=(
'python-tabulate'
'python-yaml'
)
-makedepends=('python-setuptools')
+makedepends=('python-setuptools' 'python-build' 'python-wheel' 'python-installer')
source=("${_pkgname}::git+https://github.com/getpatchwork/git-pw.git#tag=${_tag}")
sha256sums=('SKIP')
+build() {
+ cd ${srcdir}/${_pkgname}
+ python -m build --wheel --no-isolation
+}
+
package() {
- cd ${_pkgname}
- python setup.py install --root="${pkgdir}" --optimize=1
+ cd ${srcdir}/${_pkgname}
+ python -m installer --destdir="${pkgdir}" dist/*.whl
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
mkdir -p "${pkgdir}/usr/share/man/man1"
install -Dm644 man/*.1 "${pkgdir}/usr/share/man/man1/"