summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorwillemw122024-05-28 07:22:15 +0200
committerwillemw122024-05-28 07:22:15 +0200
commitfd8e21295a7fdabd4491aa78798259a07782b9a3 (patch)
tree41c495efd6cb8d28b96689d6fc3aa82ddb6b8a89 /PKGBUILD
parentc19580b825e7607f135524856afb435044b8342b (diff)
downloadaur-git-tools-git.tar.gz
Fix depends array name
Copy only git-* man pages. Update license to the new SPDX style identifier. Minor edits.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 9 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2161e1dbd81d..7273b5edfac0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: willemw <willemw12@gmail.com>
pkgname=git-tools-git
-pkgver=2020.09.r28.g12202fd
+pkgver=2022.12.r6.gfaba1cd
pkgrel=1
pkgdesc='Assorted git tools, including git-restore-mtime'
-arch=('any')
-url='https://github.com/MestreLion/git-tools'
-license=('GPL3')
-makedepends=('git' 'python') # 'bash'
+arch=(any)
+url=https://github.com/MestreLion/git-tools
+license=(GPL-3.0-or-later)
+depends=(git python)
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
source=("$pkgname::git+$url.git")
@@ -19,7 +19,9 @@ pkgver() {
package() {
install -Dm644 $pkgname/README.md -t "$pkgdir/usr/share/${pkgname%-git}"
- install -Dm644 $pkgname/man1/* -t "$pkgdir/usr/share/man/man1/"
+
+ install -Dm644 $pkgname/man1/git-* -t "$pkgdir/usr/share/man/man1/"
+
+ #install -Dm755 $pkgname/git-* -t "$pkgdir/usr/lib/git-core/"
install -Dm755 $pkgname/git-* -t "$pkgdir/usr/bin/"
}
-