summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHyacinthe Cartiaux2015-08-20 00:12:59 +0200
committerHyacinthe Cartiaux2015-08-20 00:12:59 +0200
commit0f936ff0af10c68af9aaa5a7cadfeb00e6a5cc63 (patch)
tree9c5d9dd3fcc060d14f15c831a7e8fbf399661520 /PKGBUILD
downloadaur-gitflow-git.tar.gz
Import from AUR3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c3056f2dcac0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Contributor: delor <bartekpiech@gmail com>
+
+pkgname=gitflow-git
+pkgver=20130316
+pkgrel=1
+pkgdesc="Git extensions to provide high-level repository operations for Vincent Driessen's branching model."
+arch=('any')
+url="http://github.com/nvie/gitflow"
+license=('BSD')
+depends=('git')
+
+_gitroot="git://github.com/nvie/gitflow.git"
+_gitname="gitflow"
+
+build() {
+ msg "Connecting to GIT server"
+
+ if [ -d ${srcdir}/$_gitname ] ; then
+ cd ${srcdir}/$_gitname && git pull origin || return 1
+ msg "The local files are updated."
+ else
+ git clone $_gitroot $_gitname || return 1
+ fi
+
+ msg "GIT checkout done or server timeout"
+
+ msg "Getting submodule"
+
+ cd ${srcdir}/${_gitname}
+ git submodule init
+ git submodule update
+
+ msg "Submodule checkout done or server timeout"
+}
+
+package() {
+ msg "Starting make"
+
+ cd "${srcdir}/${_gitname}"
+ make prefix=/${pkgdir}/usr install
+
+ install -Dm644 "$srcdir/$_gitname/LICENSE" \
+ "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+