summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSimon Gardling2020-03-02 14:23:55 -0500
committerSimon Gardling2020-03-02 14:23:55 -0500
commit1611f61c8fd318b1524c5176389a6ce1d5d9aee6 (patch)
tree3b1a87757528880a3ca6dd457d2546db5a5dac92 /PKGBUILD
parenteac63ecac4f653856096056ad994a54784cf2664 (diff)
downloadaur-gjs-dev.tar.gz
auto update version to latest tag
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3465991d926f..8e98238eddf1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,16 +12,18 @@ makedepends=('gobject-introspection' 'git' 'autoconf-archive' 'sysprof' 'meson')
checkdepends=('valgrind' 'xorg-server-xvfb')
provides=('gjs')
conflicts=('gjs')
-_commit=016300e9a2fda5a310b4a42a487355e68491a1fa # tags/1.63.91^0
-source=("git+https://gitlab.gnome.org/GNOME/gjs.git#commit=$_commit")
+source=("git+https://gitlab.gnome.org/GNOME/gjs.git")
sha512sums=('SKIP')
pkgver() {
cd $_pkgname
- git describe --tags | sed 's/-/+/g'
+ git describe --abbrev=0
}
build() {
+ cd $_pkgname
+ git checkout tags/$pkgver
+ cd ..
arch-meson $_pkgname build
ninja -C build
}