summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorxiota2024-10-01 09:58:13 +0000
committerxiota2024-10-01 10:03:21 +0000
commit3ddc276952b630929771aaf5a0ea3059691fbd2a (patch)
treebbd06fff12cfbfae3af62db14403df5f71e7267b /PKGBUILD
parent046aa9b594bb4b6f4044134f2bfe9f62d0fed793 (diff)
downloadaur-glibc-eac-roco.tar.gz
fixups
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 20 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1595baf570e3..fb785a4639d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,6 +2,9 @@
# This package syncs with core/glibc on rebuild.
+pkgver=2.40+r16+gaa533d58ff
+pkgrel=2
+
## options
: ${_build_roco=true}
@@ -31,11 +34,26 @@ if [ ! -e "$_file" ]; then
done
fi
+# fixups
+sed -E -e 's&^(pkgver=.*)$&_\1&' \
+ -e 's&^(pkgrel=.*)$&_\1&' \
+ -e 's&abbrev=[0-9]+&abbrev=10&' \
+ -i "arch-glibc/PKGBUILD"
+
# package
source "arch-glibc/PKGBUILD"
if [ "${_build_roco::1}" == "t" ]; then
- source "PKGBUILD.roco.append"
+ source "$startdir/PKGBUILD.roco.append"
else
- source "PKGBUILD.eac.append"
+ source "$startdir/PKGBUILD.eac.append"
fi
+
+source+=(
+ 'PKGBUILD.eac.append'
+ 'PKGBUILD.roco.append'
+)
+b2sums+=(
+ 'SKIP'
+ 'SKIP'
+)