summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorkleintux2023-10-02 16:06:26 +0200
committerkleintux2023-10-02 16:06:26 +0200
commit59aa247cbcb3ae4fa5e079bb985dbf93098e7d95 (patch)
tree14673c172389bbab45170cdb700490d24ac61774 /PKGBUILD
parent95661cbe1d5f059cece3b098e9894618bcd43eb5 (diff)
downloadaur-glmviz-git.tar.gz
added git as makedependency
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d511874930ee..1d7d3556275e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,27 @@
-# Maintainer: Pablo Moyano (p4block)
+# Contributor: <reg-archlinux AT klein DOT tuxli DOT ch>
+# Contributor: Pablo Moyano (p4block)
+
pkgname=glmviz-git
pkgver=1.0
-pkgrel=1
+pkgrel=2
pkgdesc='High framerate, dB correct OpenGL music visualizer with FiFo buffers and PulseAudio input support'
-arch=('x86_64')
+arch=('any')
url='https://github.com/hannesha/GLMViz'
license=('GPL3')
-depends=(glm fftw glfw-x11 libconfig)
+depends=('glm' 'fftw' 'glfw-x11' 'libconfig')
+makedepends=('git')
optdepends=(pulseaudio)
source=("git+https://github.com/hannesha/GLMViz.git")
md5sums=('SKIP')
build() {
-
cd "${srcdir}/GLMViz"
mkdir -p build
cd build
cmake ..
-
}
package() {
cd "${srcdir}/GLMViz/build"
make DESTDIR=${pkgdir} install
-
}