summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChocobo12023-09-08 17:30:53 +0800
committerChocobo12023-09-08 17:33:41 +0800
commita75145da7d701ae8b17d2dd1f2edf1a767fa0598 (patch)
tree60104a86dc427d336f1b4a8a27f80cdf94807939 /PKGBUILD
parent8354b8f10e1b568feac41d1d1582128385265674 (diff)
downloadaur-glu-git.tar.gz
upgpkg: glu-git 9.0.3.r0.ga2b96c7-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD57
1 files changed, 35 insertions, 22 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 32dd4ed8e300..05dae1a503e0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,52 @@
-# Maintainer: Vincent Grande <shoober420@gmail.com>
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+# Previous maintainer: Vincent Grande <shoober420@gmail.com>
# Contributor: Andreas Radke <andyrtr@archlinux.org>
# Contributor: Laurent Carlier <lordheavym@gmail.com>
pkgname=glu-git
-pkgver=9.0.1
+pkgver=9.0.3.r0.ga2b96c7
pkgrel=1
-pkgdesc="Mesa OpenGL Utility library"
-arch=('x86_64')
-url="https://cgit.freedesktop.org/mesa/glu/"
+pkgdesc="Mesa OpenGL utility library"
+arch=('i686' 'x86_64')
+url="https://gitlab.freedesktop.org/mesa/glu"
license=('LGPL')
-depends=('libgl')
-provides=(glu)
-conflicts=(glu)
+depends=('gcc-libs' 'libgl')
+makedepends=('git' 'meson')
+provides=("glu=$pkgver")
+conflicts=('glu')
+options=('staticlibs')
source=("git+https://gitlab.freedesktop.org/mesa/glu.git")
-sha512sums=('SKIP')
-#validpgpkeys=('3BB639E56F861FA2E86505690FDD682D974CA72A') # "Matt Turner <mattst88@gmail.com>"
+sha256sums=('SKIP')
+
pkgver() {
- cd glu
- git describe --tags | sed 's/-/+/g'
+ cd "glu"
+
+ _tag=$(git tag -l --sort -v:refname | grep -E '^glu-[0-9\.]+$' | head -n1)
+ _rev=$(git rev-list --count $_tag..HEAD)
+ _hash=$(git rev-parse --short HEAD)
+ printf "%s.r%s.g%s" "$_tag" "$_rev" "$_hash" | sed 's/^glu-//'
}
build() {
- cd glu
- ./autogen.sh
- ./configure --prefix=/usr --disable-static --disable-debug
- make
+ cd "glu"
+
+ meson setup \
+ --buildtype=plain \
+ --prefix="/usr" \
+ -Ddefault_library="both" \
+ "_build"
+ meson compile -C "_build"
}
-#check() {
-# cd glu
-# make -k check
-#}
+check() {
+ cd "glu"
+
+ meson test -C "_build"
+}
package() {
- cd glu
- make DESTDIR="$pkgdir/" install
+ cd "glu"
+
+ meson install -C "_build" --destdir "$pkgdir"
}