summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristopher Lopes2018-08-19 11:58:38 -0700
committerChristopher Lopes2018-08-19 14:25:57 -0700
commitee191f7eeda7ee39d4dd90cc5a415382f8b868d2 (patch)
tree2ddfc48e50e10374618e30d3cac084fe2614dabb /PKGBUILD
parent89877b502cad445b0ecfd72a7e6b8589d3b44e5f (diff)
downloadaur-glyph-bin.tar.gz
Resolve issues discovered when running namcap on the package
- Add a license - Include dependency - Use appropriate variable names
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 10 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a19d86ea2d9f..edfc53114989 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,20 @@
pkgname=glyph-bin
_pkgname=glyph
pkgver=0.3.1
-pkgrel=1
+pkgrel=2
pkgdesc="A static site generator utilizing Github issues and pages."
arch=('x86_64')
url='https://github.com/dbriemann/glyph'
license=('MIT')
-source_x86_64=("$url/releases/download/v$pkgver-beta/$_pkgname")
-sha256sums_x86_64=('87409c27020bc7db3f25c3a9b1761ecccea0c58d5a8f3dcf952f3a990f7edc9c')
+source=("$url/releases/download/v$pkgver-beta/$_pkgname"
+ 'https://raw.githubusercontent.com/dbriemann/glyph/master/LICENSE')
+sha256sums=('87409c27020bc7db3f25c3a9b1761ecccea0c58d5a8f3dcf952f3a990f7edc9c'
+ 'dad68ea093e446e0fddeb016cb84a03e5bf7bd77d7200a2e274779bf6a652dc5')
+depends=(glibc)
package() {
- install -Dm755 "${srcdir}/${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
+ # License
+ install -D -m644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ install -D -m755 "${srcdir}/${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
}