summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichal Wojdyla2024-04-01 22:50:25 +0200
committerMichal Wojdyla2024-04-01 22:50:25 +0200
commit5e1cf67f537d7f44d0a17e0d186b3e67dd1de94a (patch)
tree98ecc8b28607634c35af7ce213702bcde7034eed /PKGBUILD
parent12bf011508d43e652a1159393689ec1cfbbca270 (diff)
downloadaur-gnome-break-timer-git.tar.gz
build with meson
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 8 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c76816abe956..be060cc7831e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
-# Maintainer: Phillip Wood <phillip.wood@dunelm.org.uk>
+# Contributor: Phillip Wood <phillip.wood@dunelm.org.uk>
pkgname='gnome-break-timer-git'
_pkgname=${pkgname%-git}
-pkgver=1
+pkgver=3.1.0_1_gceef277
pkgrel=1
epoch=
pkgdesc="The new typing break for GNOME, (replaces gnome-typing-break-bzr & drwright)"
@@ -9,8 +9,8 @@ arch=('x86_64' 'i686')
url='https://wiki.gnome.org/GnomeBreakTimer'
license=('GPL3')
groups=()
-depends=('libnotify' 'libcanberra' 'libgee06' 'json-glib' 'libxtst' 'gtk3')
-makedepends=('vala' 'git' 'intltool')
+depends=('glib2' 'gsound' 'glibc' 'hicolor-icon-theme' 'libadwaita' 'graphene' 'gtk4' 'cairo' 'json-glib' 'dconf')
+makedepends=('blueprint-compiler' 'git' 'meson' 'vala')
checkdepends=()
optdepends=()
provides=()
@@ -20,7 +20,7 @@ backup=()
options=(!makeflags)
install="$pkgname.install"
changelog=
-source=("git://git.gnome.org/gnome-break-timer.git"
+source=("git+https://gitlab.gnome.org/GNOME/gnome-break-timer.git"
"$pkgname.install")
noextract=()
sha256sums=('SKIP'
@@ -31,14 +31,10 @@ pkgver() {
}
build() {
- cd "$srcdir/$_pkgname"
- ./autogen.sh --prefix=/usr --sysconfdir=/etc \
- --localstatedir=/var --libexecdir=/usr/lib/$pkgname \
- --disable-static --disable-schemas-compile
- make
+ arch-meson $_pkgname build
+ meson compile -C build
}
package() {
- cd "$srcdir/$_pkgname"
- make DESTDIR="$pkgdir/" install
+ meson install -C build --destdir "$pkgdir"
}