summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMuflone2015-06-13 17:59:17 +0200
committerMuflone2015-06-13 17:59:17 +0200
commit62118f7190b31789c92c434a4810c10532f0b367 (patch)
tree1b8684cdcc05ed9c98a7f06418563233d7e3bf1b /PKGBUILD
downloadaur-gnome-encfs-hg.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0fb050e0bf65
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Muflone <webreg(at)vbsimple.net>
+# Contributor: Jonathan Curran <joncfoo at gmail com>
+# Contributor: Heiko Baums <heiko@baums-on-web.de>
+# Contributor: Lucas SaliƩs Brum <lucas@archlinux.com.br>
+
+pkgname=gnome-encfs-hg
+pkgver=30
+pkgrel=1
+pkgdesc="GNOME Keyring integration for EncFS folders"
+url="https://bitbucket.org/obensonne/gnome-encfs"
+arch=('any')
+license=('GPL3')
+depends=('encfs' 'python2' 'python2-gnomekeyring' 'python2-xdg' 'python2-gnomekeyring')
+makedepends=('mercurial')
+source=("${pkgname%-*}"::"hg+https://bitbucket.org/obensonne/gnome-encfs")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname%-*}"
+ hg identify -n
+}
+
+prepare() {
+ cd "${pkgname%-*}"
+ sed -i -e "s|bin\/python|bin\/python2|" gnome-encfs
+}
+
+package() {
+ cd "${pkgname%-*}"
+ install -D -m755 gnome-encfs "${pkgdir}/usr/bin/${pkgname%-*}"
+}