summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorIgor Dyatlov2021-08-14 19:54:28 +0300
committerIgor Dyatlov2021-08-14 19:54:28 +0300
commita06dee4f186478a56fc279c9769d1e3ba361a121 (patch)
treefe495cc294bebd97b7081c5b510e9ce03c33541b /PKGBUILD
downloadaur-gnome-metronome-git.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..902f687a5306
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Igor Dyatlov <dyatlov.igor@protonmail.com>
+
+pkgname=gnome-metronome-git
+_pkgname=metronome
+pkgver=1.0.0.r0.g43f1728
+pkgrel=1
+pkgdesc="Practice music with a regular tempo"
+arch=('x86_64')
+url="https://gitlab.gnome.org/aplazas/metronome"
+license=('GPL3')
+depends=('glib2' 'gstreamer' 'gst-plugins-base' 'libsass' 'sassc' 'gtk4' 'libadwaita')
+makedepends=('git' 'meson' 'rust')
+checkdepends=('appstream-glib')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=(git+$url.git)
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${_pkgname%-git}"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ arch-meson ${_pkgname%-git} build
+ meson compile -C build
+}
+
+check() {
+ meson test -C build --print-errorlogs
+}
+
+package() {
+ DESTDIR="${pkgdir}" meson install -C build
+}